January 26

TP-Link WR1043ND v2 VLAN/ Switch Config on Open WRT

After a lot of research and some help from  here i configured and split the hardware switch

Extra notes:

Note 1: I not 100% sure, but if you change the WAN from VLAN 2 things are not working…
Note 2: The eth1.X should match the VLAN ID ( i didn’t know that, so it might help someone smile )
Note 3: Running BARRIER BREAKER (Bleeding Edge, r39319)
Note 4: If you keep the reset button (WPS/Reset) for more that 15″ the device resets to defaults (IP 192.168.1.1, telnet enabled )

 

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd30:0c4a:0bba::/48'

config interface 'lan1'
        option ifname 'eth1.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'lan2'
        option ifname 'eth1.3'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option type 'bridge'

config interface 'lan3'
        option ifname 'eth1.4'
        option proto 'static'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'
        option type 'bridge'

config interface 'lan4'
        option ifname 'eth1.5'
        option proto 'static'
        option ipaddr '192.168.4.1'
        option netmask '255.255.255.0'
        option type 'bridge'

config interface 'wan'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.100.100'
        option netmask '255.255.255.0'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 1'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '0t 4'
        option vid '3'

config switch_vlan
        option device 'switch0'
        option vlan '4'
        option ports '0t 3'
        option vid '4'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 6'
        option vid '2'

config switch_vlan
        option device 'switch0'
        option vlan '5'
        option ports '0t 2'
        option vid '5'

 

Tags: , , ,
Copyright © 1998. All rights reserved.

Posted January 26, 2014 by RaNd in category "/etc/config

Select comment form

Loading Facebook Comments ...

Leave a Reply

Your email address will not be published. Required fields are marked *

12 + nineteen =