January 27

TP-Link TL-WR1043ND Multiwan (3 WAN interfaces)

Just a sample config of TP-Link TL-WR1043ND with 3 WAN interfaces and Multiwan Module for load-balance :


/etc/config/network


config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.20.1'

config interface 'wan1'
option ifname 'eth0.2'
option proto 'static'
option netmask '255.255.255.0'
option dns '194.177.210.210 194.177.210.211'
option ipaddr '192.168.21.2'
option gateway '192.168.21.1'

config interface 'wan2'
option ifname 'eth0.3'
option proto 'static'
option netmask '255.255.255.0'
option dns '194.177.210.210 194.177.210.211'
option ipaddr '192.168.11.9'
option gateway '192.168.11.1'

config interface 'wan3'
option ifname 'eth0.4'
option proto 'static'
option netmask '255.255.255.0'
option dns '194.177.210.210 194.177.210.211'
option ipaddr '192.168.23.2'
option gateway '192.168.23.2'

config switch
option name 'rtl8366rb'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'rtl8366rb'
option vlan '1'
option ports '1 2  5t'

config switch_vlan
option device 'rtl8366rb'
option vlan '2'
option ports '3 5t'

config switch_vlan
option device 'rtl8366rb'
option vlan '3'
option ports '4 5t'

config switch_vlan
option device 'rtl8366rb'
option vlan '4'
option ports '0 5t'

config interface 'VPN'
option proto 'none'
option ifname 'tun0'

/etc/config/multiwan


config multiwan 'config'
option health_monitor 'serial'
option debug '1'
option enabled '1'
option default_route 'balancer'

config interface 'wan1'
option health_recovery_retries '5'
option dns '194.177.210.211 194.177.210.210'
option timeout '4'
option weight '10'
option health_interval '10'
option health_fail_retries '3'
option failover_to 'balancer'
option icmp_hosts '8.8.8.8'

config interface 'wan2'
option timeout '3'
option health_recovery_retries '5'
option dns '194.177.210.211 194.177.210.210'
option weight '10'
option health_interval '10'
option health_fail_retries '3'
option failover_to 'balancer'
option icmp_hosts '8.8.8.8'

config interface 'wan3'
option timeout '3'
option health_recovery_retries '5'
option dns '194.177.210.211 194.177.210.210'
option weight '10'
option health_fail_retries '20'
option health_interval '10'
option failover_to 'balancer'
option icmp_hosts '8.8.8.8'

config mwanfw
option wanrule 'fastbalancer'

 

 


Tags:

Copyright © 1998. All rights reserved.

Posted January 27, 2014 by RaNd in category "/etc/config

Select comment form

Loading Facebook Comments ...

Leave a Reply

Your email address will not be published. Required fields are marked *

17 + eighteen =